Fix - Can't sync calendar events from Android Tablet to Android Phone


#1

Hi, I have the Galaxys7 phone and the Galaxy Tab A Tablet. Both have up to date software. Google Calendar, Samsung Calendar, and DigiCal Calendar are installed on both. Lately, I’m unable to sync my calendars from my Tablet to the phone, but I can sync from phone to tablet. Entering an event into any installed calendars, they show up in Google Calendar on DigiCal calendar and Samsung calendar.
The Google calendars on both devices are set up identical. Have placed them side by side and tapped “Refresh”. It says syncing but at the end, nothing has happened. I have also uninstalled and reinstalled my Google account. It seems that my Tab A can receive but not send calendar events to the phone.
I have looked at all possible settings. Obviously, I’m missing something. Had this problem once before but can’t remember how it was resolved. Maybe the events on the Galaxy Tab A are only saved to the device? If this is the case, I don’t know how to change from “saving to the device or saving to cloud.” Where do I find if the calendar events on my Tab A are saved to device or cloud?
If you have any suggestions, I would appreciate it very much. Thanks in advance.


#2

If you are using Android tablet, then go to settings > Accounts > Remove google account and then re add it. Make sure to give all permissions. It should work. If not then try an alternative app for Calendar.


#3

Thank you so much for writing, Steve. Unfortunately, it didn’t help. I have removed and reinstalled Google first on the tablet and then on both devices with the identical information. Also, Google, Samsung and DigiCal calendars are working well together on both tablet and phone. The problem is that I can sync calendar info. from phone to tablet but not from tab. to phone. Maybe the info. on tablet is not stored on cloud? As far as I can see, I have enabled Google and Samsung cloud…I have been trying to get this problem resolved for a long time… I guess that it is in the Tab A setting somewhere.
Is there any way to see step by step instruction on how to set up Google calendar to save to cloud?
Most of all, thank you for have taken the time to answer my question.


#4

You can either have one of these issues. Try this and probably it should help.

1- Make sure new events are being added to your Google Calendar
When you create an event, check which calendar it’s being added to. If it isn’t being added to the Events calendar, you may not see it in the Google Calendar app or at calendar.google.com.

  1. Open the Google Calendar app Calendar.
  2. In the bottom right, tap Create Create.
  3. Next to the Event calendar icon Event, make sure it says Event. If you don’t see Event, tap the Event Calendar icon to switch to the correct calendar.

2- Check that Calendar is synced

  1. Open the Google Calendar app Calendar.
  2. In the top left, tap Menu Menu.
  3. Tap Settings Settings.
  4. Tap the name of the calendar that isn’t showing up. If you don’t see the calendar listed, tap Show more .
  5. At the top of the page, make sure Sync is on (blue). You’ll only see the Sync setting for calendars you’ve created, but not your primary calendar (this is usually called “Events” unless you’ve changed its name).
    Note: It might take some time for your events to show up after you turn on sync.

3- Make sure Calendar storage is turned on

  1. Open the Settings app on your device (not the “Google Settings” app).
  2. Tap Apps or Apps & notifications and then App info .
  3. In the top right, tap More and then and then Show system and then Calendar storage .

4- Check your device’s storage
Calendar stops syncing if your device is running out of storage.

  1. Open the Settings app on your device (not the “Google Settings” app).
  2. Find the Storage section.
  3. If you need to clear space, try uninstalling apps you don’t use or deleting files or photos from your device.

5- Clear your Calendar app data
Important: These steps may cause you to lose some unsynced data. Any event information you can’t see on Google Calendar on your computer will be lost. Only try these steps if nothing else above worked.

  1. Open the Settings app on your device (not the “Google Settings” app).
  2. Tap the Apps or Apps & notifications section. You may need to scroll down or go to a different page in settings.
  3. Tap App info to view the list of all apps.
  4. Select Calendar Calendar.
  5. Tap Storage and then Clear data and then OK .
  6. If you see “Calendar Storage” in the list, clear data for that app too.
  7. Turn off your device, then turn it back on again.

You can read the complete guide here. Let me know if it helps.


#5

Steve, thank you for your detailed instructions. I appreciate it very much. I’m sorry that I haven’t had a chance to get back to you sooner…have been sick.

It finally works now! I think what made the difference is clearing the cache and data from Google Calendar and rebooting.

Now, all calendars are syncing great, including the stock calendar on my Windows laptop.

Most of all, thank you, thank you!!!