Many incompatible apps on Xiaomi Mi Mix 2


#1

I could really use some help here. I just bought a Xiaomi Mi Mix 2 and there are quite a few apps that turn up a “App not installed” error when i try to install them.

I’m currently running lineage os 15.1 without gapps.

Here’s what I’ve tried:

  1. Moving apk to system/app and changing permission to force install as a system app. The app shows up, but crashes on launch.

  2. Flashing MiUI 9 and 10, with gapps. Play store simply says the apps are incompatible with my device. Direct apk install same error as before.

  3. I tried editing build.prop because i thought maybe i could trick the phone into thinking the app was compatible. No change (Though i might have made a mistake on this one, i dunno)

  4. Since the apps wouldn’t even run as system apps, I didn’t wanna start trying to install from USB. Didn’t seem that would fix anything, let me know if I’m wrong

  5. I tried flashing the latest firmware from https://forum.xda-developers.com/mi-mix-2/development/firmware-xiaomi-mi-mix-2-t3741667 . No change.

The apps that do not work include:
Facebook messenger
Spotify
Swiftkey keyboard - and 3 other keyboard apps i tried (So now I’m stuck with default)
Monese (My banking app)

Some of these are really annoying to be missing, though i did find that Disa works for facebook. Spotify, keyboard and monese really sucks to be missing.

I’d say about 20% of my apps failed to install, with all keyboard apps failing to install. Except one, which then crashes upon launch. Maybe it’s because keyboard apps are so deeply integrated into the ROM.

Also USB OTG is not working, but that’s a minor issue campared to the above. Could just be a bad adapter.

Could i replace the kernel? Would that help?

Any help would be much appreciated!


#2

I would recommend you to replace kernel with original Android kernel. Uninstall LineageOS and see if this helps. LineageOS always remain up to date so many apps are not compatible with android latest version. Give this a try and let me know.


#3

Thank you for your reply Steve :slight_smile:

I have tried using the Xiaomi flash tool to flash both MIUI 9 and MIUI 10, which also locked my phone again. I imagine this is a full factory reset - including the kernel? Still had the same issue.

If that does not reset the kernel i will need some advice on how to install the original android kernel :slight_smile: I have twrp installed if that makes flashing easier.


#4

Finally managed to fix it, though I’m not exactly sure why :slight_smile:

I installed Xposed framework, Xposed installer, XprivacyLua and Gapps on my device (Still running lineage os 15.1). I restricted all data to Gapps, except account name. This includes giving google play services a fake IMEI, which allowed me to get around the “This app is not compatible with your device” error in play store.

I expected the install would fail or the app would fail to run, but everything is working!

Anyway, kind of an elaborate solution, but now it’s here in case anyone runs into the same issue :slight_smile: