Pokemon Failed to detect location - Help Required


#1

I am getting the issue with Pokemon go. I am using flying GPS to play Pokemon go.
Can anyone please help me to solve this!
I attached a screenshot of that u can see.


#2

Hi, this seems a common problem. Have you looked at this topic


#3

The app can now detect FlyGPS and show this error. Try not to use any mocking app and see if problems get solved.


#4
  • Go to developer Options and set GPS JoyStick as the Mock Locations app. (No root needed!)
  • Enable Indirect Mocking option in the GPS JoyStick Settings screen. *Use this setting only if you are not using any other method.

#5

Don’t use Fly GPS, it is detectable by Pokemon GO and will give you failed to detect location error.

I will suggest that you download and install the latest version of GPS JoyStick app by The App Ninjas from here, then make it a system app using Link2SD or any other app you want (you will need to have root access for this). Then restart your phone.

Once all is done, now you can run GPS JoyStick app and spoof in Pokemon GO without any need to enable mock locations and the fake GPS location app will remain undetected by the game. I hope this helps.

In case you are still experiencing any problem then feel free to ask. I will guide you further.


#6

Thanks. That worked for me, now I can play this game easily. :smile:


#7

Hi farzan,

Does GPS Joystick still work on rooted phones now?


#8

Still working for some people but not for everyone.


#9

Hi, @Zhikai_Lim!

Yes, still works for me and my friends! But you need to have a systemless root (like Magisk) to be able to spoof in Pokemon GO without getting your account banned.

Also, if you are planning to use GPS JoyStick then don’t forget to use the Privacy Mode feature of GPS JoyStick to prevent Pokemon GO from detecting the location mocking app.

Moreover, some non-rooted users were able to make GPS JoyStick work by using tin foil and wrapping it around the GPS chip of their phone. That prevents your device’s GPS from detecting your real location and stops rubberbanding, which usually causes a temporary ban on your account.


#13

Hi @farzanhussain
Sir!
So, what is the best procedure now?
1.Install GPS JoyStick then standard root, move app to system, unroot - or we dont need?! and play
2.Install GPS JoyStick then root (but by Magisk) then move app to system, unroot - or not?! and play
3.any other?..
*It is possibly to play on rooted device? (I always get information about wrong OS, system software that is not compatibile withPGo


#14

Thanks for the reply. If i’m using a Samsung S7 Edge, is it possible to do the systemless root even if my phone has the latest security date?


#15

Hi Farzan,

I am using the ASUS Zenpad 8.0 z380kl , model P024 system. Can you advise me which root package I should try. I was using Fake GPS on this Zenpad without any issue till my kid updated my os software fr KitKat 4.4 to Adroid 6.0.1. Now I kept getting failed to detect location.

Hope to have yr kind advice pse.

Many thanks-Kuan


#16

I have the Dame problem. Can somebody help me?


#17

It’s a great discussion…